Slow Bank Deposits in Malaysia
Incident Report for Luno
Resolved
Deposits are being processed as normal.
Posted May 27, 2021 - 05:42 UTC
Investigating
We're aware of a delay with deposits via Bank Transfer and our team is currently investigating it. We're working on having this resolved soon. In the meantime, please make use of FPX to make deposits into your Luno wallet.
Posted May 20, 2021 - 11:14 UTC