Exchange order book delays
Incident Report for
Luno
Resolved
A fix has been deployed which has resolved the issue.
We appreciate your understanding in this matter.
Posted
Sep
30
,
2024
-
19:50
UTC
Identified
We have identified an issue that's causing a delay when updating the order book on web browser.
Our team is working on fixing this as a priority.
Posted
Sep
30
,
2024
-
18:29
UTC
×
Subscribe to Incident
Subscribe to updates for
Exchange order book delays
via . You'll receive .