Update: DOT/MYR is available for trading on our Exchange. More updates to follow soon.
Posted Jul 20, 2025 - 08:57 UTC
Identified
We are currently experiencing a technical issue with creating quotes for the DOT/MYR pair on our Instant Buy and Sell feature. Our team is promptly working on resolving this issue and will update as soon as possible. Thank you for your continued patience.