Delayed Balance Updates

Incident Report for Luno

Resolved

We have confirmed that this has been resolved and balances are being updated as expected.

We apologise for any inconvenience caused.
Posted Aug 29, 2023 - 17:18 UTC

Monitoring

We have pushed out a fix for this and we are seeing balances being updated as normal, we will continue to monitor this to ensure there are no further issues.
Posted Aug 29, 2023 - 17:01 UTC

Investigating

We are currently experiencing an issue causing delayed balance updates for some customers.

We are working on this as a priority and hope to see this resolved soon.
Posted Aug 29, 2023 - 16:52 UTC