Delayed bank withdrawals in Malaysia.

Incident Report for Luno

Resolved

Withdrawals are now processed as usual.
Posted Dec 16, 2025 - 08:54 UTC

Monitoring

There is a temporary delay with Malaysia withdrawals requested on the 15th of December 2025, 3:45 PM to 16th of December, 12 PM. We’re working with the bank to get this resolved the soon.

Any withdrawals submitted during this time

15th December 2025, 3:45 PM to 16th December, 9:59 AM are expected to reflect by today at 8:20 PM.
16th December 2025, 10 AM to 11:59 AM are expected to reflect by today 11PM

You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934

We apologise for the inconvenience caused.
Posted Dec 16, 2025 - 04:16 UTC