Delayed deposits and withdrawals in Kenya

Incident Report for Luno

Resolved

This has been resolved.

Customers can deposit and withdrawal without any delays.

We appreciate your patience.
Posted Feb 02, 2025 - 10:53 UTC

Identified

Customers may experience delays with deposits and withdrawals in Kenya.

Unfortunately, this issue is with our payment provider, we are working closely with them to resolve this as soon as possible.

We appreciate your understanding and apologise for any inconvenience this may cause.
Posted Jan 31, 2025 - 18:50 UTC