Delayed withdrawals in South Africa
Incident Report for Luno
Resolved
The issue has been fully resolved. All affected withdrawals have been successfully processed, and there are no further delays.

Thank you for your patience.
Posted Nov 15, 2024 - 12:09 UTC
Monitoring
All pending withdrawals have now been successfully processed. We will continue to monitor to ensure there are no further delays.
Posted Nov 15, 2024 - 09:55 UTC
Identified
We have identified the issue affecting a small number of withdrawals. A fix is currently being implemented, and the impacted transactions will be reprocessed shortly.

We appreciate your patience.
Posted Nov 15, 2024 - 09:38 UTC
Investigating
We are currently investigating an issue causing delayed withdrawals for South African customers, we are working on resolving this as soon as possible.
Posted Nov 15, 2024 - 09:02 UTC