Slow deposits and withdrawals in Nigeria
Incident Report for Luno
Resolved
The issue causing some withdrawals and deposits to be unsuccessful via vouchers in Nigeria has been resolved.

We apologise for any inconvenience caused.
Posted Aug 11, 2022 - 10:16 UTC
Investigating
We are aware of an issue that is causing some withdrawals and deposits to be unsuccessful via vouchers in Nigeria.

We hope to see this resolved as soon as possible.

We apologise for any inconvenience caused.
Posted Aug 11, 2022 - 04:06 UTC