Business account verification delays

Incident Report for Luno

Resolved

Update:

We have deployed a fix and business account verification is processing as normal.

We appreciate your understanding in this matter.
Posted Mar 04, 2025 - 10:56 UTC

Identified

We have identified an issue causing the business account verification process to get stuck.

This means customers who are attempting to create a business account may experience delays.

Our team is working on this as a priority.
Posted Mar 04, 2025 - 09:38 UTC