Order status delays

Incident Report for Luno

Resolved

This has been fully resolved. We apologise for any inconvenience caused.
Posted Sep 14, 2022 - 19:49 UTC

Monitoring

The implemented resolution was successful. Customers are able to place and cancel orders on the exchange. Our engineers will continue to monitor the progress to ensure that the exchange is fully operational.
Posted Sep 14, 2022 - 15:42 UTC

Identified

The issue has been identified and we are implementing a fix to ensure that the exchange is restored to an optimal working state.
Posted Sep 14, 2022 - 15:01 UTC

Update

We are continuing to investigate this issue. Some customers may see delays when trying to cancel orders on the exchange. We are looking into this as a priority and we will update as soon as we have identified the cause.
Posted Sep 14, 2022 - 13:41 UTC

Investigating

We are currently investigating delays in order status and trades reflected in customer's accounts. Updates to follow.
Posted Sep 14, 2022 - 12:33 UTC