Delayed Deposits in Indonesia

Incident Report for Luno

Resolved

Update:

We are no longer seeing deposit delays for Indonesian customers.

We appreciate your understanding in this matter.
Posted Jun 03, 2026 - 07:00 UTC

Identified

We have identified an issue causing delays with deposits in Indonesia.

Customers attempting to deposit in Indonesia may experience slower-than-usual deposit times.

Unfortunately, this issue is with our 3rd-party banking provider and we are working to try and resolve it as soon as possible

We appreciate your understanding in this matter.
Posted Jun 03, 2026 - 06:55 UTC