Wallet/Portofilio page is temporarily unavailable on Brave Browser

Incident Report for Luno

Resolved

This incident has now been resolved.
Posted Apr 25, 2025 - 17:21 UTC

Investigating

We are currently experiencing a technical issue that has caused the Wallet/Portfolio page to become temporarily unavailable on Brave browser. We are promptly working on a fix and will provide an update shortly.
Posted Apr 25, 2025 - 11:15 UTC