Instant EFT via PayU unavailable in South Africa
Incident Report for Luno
Resolved
Unfortunately deposits via Instant EFT continue to be unavailable for customers in South Africa, we will publish an update should that change in the future.

Please make use of EFT deposits. Apologies for the inconvenience caused.
Posted Jun 18, 2020 - 10:30 UTC
Update
We're continuing to work with the provider to resolve the technical issue. Deposits via Instant EFT will unfortunately remain unavailable until further notice.
Posted May 18, 2020 - 06:44 UTC
Identified
Due to an issue with PayU, deposits via Instant EFT is currently unavailable to customers in South Africa.
We're working with the provider to have this re-enabled as soon as possible.

Updates to follow.
Posted May 05, 2020 - 18:15 UTC