Delayed Withdrawals in Kenya
Incident Report for
Luno
Resolved
This incident has been resolved.
Posted
Sep
03
,
2025
-
09:30
UTC
Identified
We have identified an issue that is causing customers to experience longer-than-normal withdrawal processing times when attempting to withdraw funds.
We are working with our payment provider to resolve this issue.
We will provide updates as soon as we can. We apologise for any inconvenienced caused
Posted
Sep
02
,
2025
-
12:31
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Withdrawals in Kenya
via . You'll receive .