Delayed express withdrawals in South Africa
Incident Report for Luno
Resolved
Express withdrawals are now being processed as normal.

We apologise for any inconvenience caused.
Posted Jan 23, 2025 - 11:12 UTC
Monitoring
A fix has been successfully implemented, and express withdrawals are now being processed as normal. We will continue to monitor this closely.

We apologise for any inconvenience and appreciate your patience.
Posted Jan 22, 2025 - 16:07 UTC
Identified
We are currently experiencing temporary delays with express withdrawals due to some unexpected downtime with our banking partner.

Please rest assured that we are in direct communication with the bank and are actively working to resolve the issue as quickly as possible.

We will provide updates as soon as we have more information.
Posted Jan 22, 2025 - 15:13 UTC