FTM cryptocurrency unavailable on Instant buy and Sell

Incident Report for Luno

Resolved

A fix has been deployed, and there should be no further issues with attempts to buy and sell FTM using Instant Buy and Sell.

We appreciate your patience and understanding in this matter.
Posted Apr 24, 2025 - 13:15 UTC

Identified

We have identified an issue that is not allowing our customers to buy and sell FTM cryptocurrency when using the Instant buy and sell feature on your Luno app.

Customers will not see the Buy or Sell button when viewing FTM cryptocurrency.

Buying and selling FTM on the Exchange remains unaffected.

Our team is working on this as a priority.

Updates to follow
Posted Apr 24, 2025 - 13:03 UTC