Checkout deposits in Europe
Incident Report for Luno
Resolved
Deposits using Checkout are working as normal for all customers.

Thanks again for your patience.
Posted May 07, 2021 - 09:37 UTC
Update
After further investigation we see that the issue seems more widespread than initially thought.

Customers in the UK and Europe are currently unable to add new cards to their wallet using Checkout while customers in Europe are unable to make a deposit using existing cards.

Customers in the UK who have previously added card details are able to make use of Instant Buy as usual.

We're working closely with Checkout to see this resolved for all customers as quickly as possible.
Posted May 06, 2021 - 16:00 UTC
Update
We are still aware of this issue and are working with Checkout on resolving this.

Please make use of an alternative payment method available to you in the interim.
Posted May 06, 2021 - 08:30 UTC
Identified
We have identified some issues with Checkout that may cause errors for some customers in Europe when attempting to make a deposit.

Our team is aware of the issue and are working on a fix as a priority.

We appreciate your patience.
Posted May 03, 2021 - 09:36 UTC