Incorrect prices shown for BTC/SGD
Incident Report for Luno
Resolved
This issue has been resolved and the rates shown for the BTC/SGD pair have returned to normal.
Posted May 09, 2022 - 07:01 UTC
Investigating
We are currently investigating an issue causing incorrect rates to be shown for the BTC/SGD pair at the moment, these rates are not impacting trades.

This also may have affected price alerts and we are working on a fix as a priority.
Posted May 08, 2022 - 12:24 UTC