Delayed bank account verification in South Africa
Incident Report for Luno
Resolved
This incident has been resolved and customers' new bank accounts are being verified without issues.
Posted Aug 07, 2022 - 10:07 UTC
Monitoring
Capitec services have resolved the issue. Our engineers will continue to monitor and ensure that accounts are being verified without further issues.
Posted Aug 06, 2022 - 08:43 UTC
Update
This delay is a result of a general issue with Capitec services. Withdrawals are processing but funds might not reflect in customer's Capitec accounts due to this issue. We will continue to monitor and update when we have more information.
Posted Aug 05, 2022 - 13:05 UTC
Identified
After some investigation, we have found that this is only affecting Capitec customers.

We will provide an update as soon as possible.
Posted Aug 05, 2022 - 08:13 UTC
Investigating
We are currently investigating an issue that affects customers in South Africa who are trying to withdraw to newly-added bank accounts. Saved and existing bank beneficiary accounts are unaffected and can still process withdrawals normally.
Posted Aug 05, 2022 - 07:56 UTC