Delayed crypto sends
Incident Report for
Luno
Resolved
This incident has been resolved.
Posted
Jun
21
,
2025
-
19:00
UTC
Monitoring
A fix has been implemented, and crypto sends are now processing successfully. We will continue monitoring for any further issues.
We apologise for any inconvenience and appreciate your patience.
Posted
Jun
21
,
2025
-
16:06
UTC
Identified
We have identified an issue that may be causing delayed crypto sends for some customers. The following cryptocurrencies are impacted:
ERC-20 (AAVE,APE,AXS,CRV,ENS,GRT,IMX,LINK,MKR,ONDO,SAND,SNX,UNI,USDC,USDT)
We are treating this issue as a priority and are actively working to resolve it. We will provide an update as soon as we have more information.
Posted
Jun
21
,
2025
-
09:59
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed crypto sends
via . You'll receive .