Deposit and withdrawal service interruption in Singapore
Incident Report for Luno
Resolved
Deposits and withdrawals are now being processed as scheduled. Thank you
Posted Sep 12, 2022 - 01:39 UTC
Identified
Our banking partner will be undergoing a service maintenance which may affect your deposits and withdrawals via bank transfer.

Affected times:
Sunday, 11 September 2022 01:00 AM - 05:00 AM

During this downtime, please use StraitsX as an alternative if you encounter any issues.

All services will resume to normal after the maintenance is complete. Thank you for your understanding.
Posted Sep 09, 2022 - 04:03 UTC