Withdrawal delays in South Africa
Incident Report for
Luno
Resolved
Update:
We are no longer seeing withdrawal delays in South Africa.
We appareciate your understanding in this matter.
Posted
Apr
29
,
2026
-
10:24
UTC
Identified
Current Status: Customers may see longer-than-normal processing times after attempting to withdraw funds.
Unfortunately, this is outside our control, as the issue lies with our 3rd-party banking partner; we are working hard to resolve it with them.
We appreciate your understanding and patience.
Updates to follow.
Posted
Apr
29
,
2026
-
08:15
UTC
×
Subscribe to Incident
Subscribe to updates for
Withdrawal delays in South Africa
via . You'll receive .