Delayed XRP sends
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any delays for XRP cryptocurrency sends.
We appreciate your understanding in this matter.
Posted
Dec
19
,
2025
-
07:18
UTC
Identified
We have identified an issue causing XRP transactions to experience longer-than-normal processing times.
Customers will experience delays when attempting to send XRP cryptocurrency
Our team is working on this as a priority.
Posted
Dec
18
,
2025
-
17:05
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed XRP sends
via . You'll receive .