Delayed BTC Sends

Incident Report for Luno

Resolved

This issue has now been resolved. Thank you for your patience.
Posted 1 month ago. Feb 25, 2025 - 22:59 UTC

Identified

The following coins are affected by the ongoing delayed sends issue:
BTC
XRP
LTC
AAVE
APE
AXS
BCH
CRV
GRT
IMX
LINK
MKR
SAND
SNX
UNI
USDC
USDT

We are working on a fix. Updates to follow
Posted 1 month ago. Feb 25, 2025 - 21:17 UTC

Investigating

We're currently experiencing an issue causing BTC sends to be delayed. We are actively working on resolving this and will update once the issue has been fixed.
Posted 1 month ago. Feb 25, 2025 - 20:53 UTC