Deposits and withdrawals service interruption in Singapore
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Jul 25, 2022 - 04:28 UTC
Update
Our bank partner will be undergoing a service maintenance which may affect your deposits and withdrawals via bank transfer.

Affected times:
Sunday, 24 July 2022 01:30 AM - 05:30 AM

During this downtime, please use StraitsX as an alternative if you encounter any issues.

All services will resume to normal after the maintenance is complete. Thank you for your understanding.
Posted Jul 22, 2022 - 08:55 UTC
Identified
Our bank partner will be undergoing a service maintenance which may affect your deposits and withdrawals via bank transfer.

Affected times:
23 July 2022, 10:00 PM - 24 July 2022, 08:00 AM

During this downtime, please use StraitsX as an alternative if you encounter any issues.

All services will resume to normal after the maintenance is complete. Thank you for your understanding.
Posted Jul 22, 2022 - 07:47 UTC