Delayed Trades On The Exchange For Low Volume Market Pairs

Incident Report for Luno

Resolved

This issue has now been resolved and we will continue to monitor.
Posted Sep 23, 2025 - 12:30 UTC

Identified

We have picked up a technical issue affecting exchange trades on all of our low volume market pairs. We're currently working on a fix and will update as soon as possible.
Posted Sep 23, 2025 - 11:19 UTC