The issues with our payment provider affecting instant buy with card deposits has been fully resolved.
You can now use card deposits as usual. We appreciate your patience.
Posted Sep 16, 2024 - 14:09 UTC
Monitoring
A fix has been successfully implemented by our payment provider, and we are currently monitoring the results.
Posted Sep 16, 2024 - 12:59 UTC
Identified
We are currently experiencing issues with one of our payment providers, which may affect customers trying to use instant buy with card deposits. Please make use of an alternative deposit/buy method that is available to you.
We are actively working with our payment provider to fix the problem as quickly as possible.