Public Holiday Reminder - Withdrawal Request will take longer than usual in MALAYSIA
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Jun 06, 2023 - 02:20 UTC
Identified
The 5th of June 2023 is a public holiday in Malaysia, during which banks do not process payments. This means any withdrawals from Luno that we send to the banks won’t be processed by them until the 6th of June 2023.

Please note that this only applies to MYR withdrawals. Crypto withdrawals are being processed as normal according to our service level agreements.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jun 02, 2023 - 07:42 UTC