Slow support and account verification response times in Indonesia
Incident Report for Luno
Resolved
Response times have returned to normal, thanks for your patience.
Posted Jul 14, 2021 - 10:16 UTC
Identified
Saat ini, kami tengah menangani jumlah tiket bantuan yang lebih tinggi dari biasanya.

Kemungkinan kami akan memerlukan waktu lebih lama untuk membalas atau memproses permintaan bantuan atau verifikasi akun Anda.

Kami mohon maaf atas ketidaknyamanan ini dan kami akan mengupayakan
untuk membantu Anda secepatnya atau maksimal 7 hari kerja.

Terima kasih atas pengertian Anda.

We’re currently experiencing an extremely high number of signups and incoming queries, and we’re working through the backlog as fast as we can.

You can expect longer than normal response times on your support queries and account verification responses. We’re sorry for the delay and we’ll do our best to get back to you within 7 working days.

Thanks so much for bearing with us.
Posted Jul 02, 2021 - 09:57 UTC