Delayed usdt withdrawals

Incident Report for Luno

Resolved

The issue has been resolved, thank you for your patience and we apologise for the inconvenienced caused.
Posted Apr 22, 2025 - 19:51 UTC

Investigating

We are experiencing slow responses on our usdt withdrawals. We are currently investigating the issue and will resolve as soon as possible. We apologise for the inconvenience caused.
Posted Apr 22, 2025 - 19:13 UTC