Delayed trades for ETH AUD

Incident Report for Luno

Resolved

The issue causing delayed trades for the ETH AUD pair has been resolved.
Posted Jul 17, 2022 - 08:29 UTC

Investigating

We are currently investigating an issue that is causing delayed trades for the ETH AUD pair.

We are looking into this as a matter of priority.
Posted Jul 17, 2022 - 08:10 UTC