Delayed deposits and withdrawals in Nigeria

Incident Report for Luno

Resolved

We are no longer experiencing issues with delays in redeeming deposits or withdrawal vouchers in Nigeria.

Thank you for your patience in this regard.
Posted Feb 22, 2023 - 06:22 UTC

Investigating

We are currently experiencing an issue that may be causing temporary delays with deposit and withdrawal voucher redemption. We are working to get this resolved as soon as possible.

We apologise for any inconvenience.
Posted Feb 21, 2023 - 07:35 UTC