Delayed NG verification
Incident Report for Luno
Resolved
Verification times in Nigeria have returned to normal.
Posted Nov 13, 2021 - 16:06 UTC
Monitoring
Our verification partner has reported good results, we're monitoring closely.
Verification times in Nigeria have returned to normal.
Posted Nov 12, 2021 - 12:10 UTC
Investigating
Our verification partner for Nigeria is currently investigating an issue that may cause delays in the verification of Nigerian customers.

This is being looked into as a priority.
Posted Nov 12, 2021 - 09:01 UTC
This incident affected: Help & account verification (Account verification).