Delayed Balance Updates
Incident Report for Luno
Resolved
We have confirmed that this has been fully resolved. Balances are being updated as expected.

We apologise for any inconvenience caused.
Posted Nov 20, 2024 - 07:47 UTC
Monitoring
We have pushed out a fix for this and we are seeing balances being updated as normal, we will continue to monitor this to ensure there are no further issues.
Posted Nov 18, 2024 - 18:14 UTC
Identified
We have identified the cause of this issue and are working on a fix.

We hope to see this resolved soon and will provide updates as soon as possible.
Posted Nov 18, 2024 - 18:06 UTC
Investigating
We are currently investigating an issue causing delayed balance updates for some customers.

We are working on this as a priority and will provide updates as soon as possible.
Posted Nov 18, 2024 - 17:39 UTC