Slow XRP receives
Incident Report for Luno
Resolved
XRP receives are being processed as normal.
Posted Jun 28, 2024 - 15:04 UTC
Update
We aren't seeing any further delays with XRP receives since 15:30 UTC yesterday.
Posted Jun 28, 2024 - 08:10 UTC
Monitoring
We have implemented a fix for delayed XRP receives and are seeing good results. We will continue to monitor the situation.
Posted Jun 27, 2024 - 15:30 UTC
Update
While we have made progress, some customers may still see delayed receiving XRP to their Luno wallet.
Our team are working on a fix as a priority, there's no need to do anything.

XRP sends remain unaffected.
Posted Jun 27, 2024 - 08:01 UTC
Identified
Customers may see slower than usual confirmation times when receiving XRP to their Luno wallets. Our team is aware of the issues, we're working on a fix.
Posted Jun 26, 2024 - 11:52 UTC