Bank transfer with Flutterwave disrupted in South Africa
Incident Report for Luno
Resolved
Card payments through Flutterwave are working again. Thank you for being patient while we worked to resolve the issue.
Posted Jun 25, 2022 - 07:28 UTC
Investigating
We are currently experiencing an issue with card payments via Flutterwave.

This service is currently unavailable. All other deposit methods are working as expected.

We are looking into this as a matter of priority.
Posted Jun 24, 2022 - 15:26 UTC