Delayed account verification
Incident Report for Luno
Resolved
No further delays since our last update, thanks for your patience.
Posted Oct 14, 2024 - 06:09 UTC
Monitoring
Account verification times have returned to normal, we're monitoring over the next few hours.
Posted Oct 12, 2024 - 18:18 UTC
Identified
We've identified the issue and are progressing towards a fix.
Posted Oct 12, 2024 - 18:08 UTC
Investigating
We're noticed a slower than normal response for account verification in all regions, we're investigating the cause.
Posted Oct 12, 2024 - 17:47 UTC