Degraded performance

Incident Report for Luno

Resolved

This incident has been resolved. Following the deployment of a fix, we monitored the platform closely and have confirmed that performance has remained stable.

We apologise for any disruption this may have caused and thank you for your patience.
Posted Aug 07, 2026 - 01:35 UTC

Monitoring

A fix has been implemented to resolve the recurrence of degraded performance. Functionality has been restored across the platform. We will continue to closely monitor the system to confirm the issue is fully resolved.
Posted Aug 07, 2026 - 00:31 UTC

Identified

We are aware of a recurrence of degraded performance affecting the platform. Our engineering team is actively investigating and working toward a resolution. We will provide a further update shortly.
Posted Aug 07, 2026 - 00:00 UTC

Monitoring

A fix has been implemented, and functionality has been restored across the platform.

We will continue to monitor for any further issues.
Posted Aug 06, 2026 - 23:20 UTC

Investigating

We are investigating an issue which may be causing degraded performance on the app as well as some customers experiencing errors when using the platform.
Posted Aug 06, 2026 - 23:13 UTC