Delayed Withdrawals In Nigeria
Incident Report for
Luno
Resolved
Our payment provider has resolved the issue, and withdrawals are no longer delayed.
Thank you for your understanding and patience.
Posted
Sep
25
,
2024
-
08:15
UTC
Identified
Customers may see slower than normal processing times when withdrawing NGN due to an issue with our payment provider.
We appreciate your understanding in this matter.
Posted
Sep
23
,
2024
-
14:33
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Withdrawals In Nigeria
via . You'll receive .