Slow account verification in Indonesia
Incident Report for Luno
Resolved
No further delays since our last update, we'll continue to monitor closely.
Posted Oct 14, 2024 - 06:10 UTC
Monitoring
While verification times have normalised further delays may occur over the weekend, we're keeping a close eye on the situation.
Posted Oct 11, 2024 - 19:13 UTC
Identified
We're seeing slower than normal account verification times in Indonesia due to downtime/service degredation with a third party.
Posted Oct 11, 2024 - 16:35 UTC