Delayed Withdrawals Nigeria
Incident Report for Luno
Resolved
The issue affecting delayed withdrawals in Nigeria has been resolved.

Thank you for your patience in this regard.
Posted Jun 09, 2022 - 14:38 UTC
Monitoring
A fix has been implemented for the issue of delayed withdrawals in Nigeria.

We will continue to monitor for any more errors.
Posted Jun 09, 2022 - 12:24 UTC
Investigating
We are currently investigating an issue which may be causing temporary delays with Nigerian bank withdrawals.

We’re working on resolving this as a matter of priority.
Posted Jun 09, 2022 - 01:47 UTC