Slow ETH send transactions
Incident Report for Luno
Resolved
No sends have been affected, this was a precautionary notice.
Posted Sep 16, 2022 - 08:07 UTC
Identified
Some customers may experience slower than normal ETH sends from 17:00 UTC. We will process your send as soon as possible, apologies for the inconvenience.

ETH receive transactions remain unaffected.
Posted Sep 15, 2022 - 20:02 UTC