Delayed account verification in Indonesia
Incident Report for Luno
Resolved
We are still working tirelessly to set up an alternative verification provider so that we can restore verification services in Indonesia as soon as possible. Further updates will be provided on this dedicated Help page article: https://www.luno.com/help/en/articles/196569045415455
Posted Oct 31, 2022 - 07:52 UTC
Update
We are still experiencing delays in onboarding and account verification. We will provide another update as soon as we have more information.
Posted Aug 12, 2022 - 09:42 UTC
Update
We are still experiencing a delay causing slow onboarding times for new customers. We don't expect this to be fixed over the weekend and we'll continue working with our provider next week. Customers who have been verified are not affected. We will provide an update as soon as we have more information.
Posted Aug 05, 2022 - 14:26 UTC
Update
We're continuing to work closely with the third party affecting our slow onboarding times for new customers, we're sincerely sorry about the delays. Customers who have already been verified are not affected, however new customers signing up and need to submit documents to be onboarded will see some delays.
Posted Aug 04, 2022 - 19:08 UTC
Update
We are currently unable to process verification requests received from July 28, 2022, due to ongoing system maintenance with the provider we use for verifications. We will provide another update once we start processing account verification again and we apologise for the inconvenience caused.
Posted Aug 01, 2022 - 08:36 UTC
Identified
We are still working with our service provider to ensure that all delayed verification requests are processed as soon as we have managed to resolve the issue. Updates will be provided as soon as we have made progress
Posted Jul 28, 2022 - 13:34 UTC
Investigating
We are experiencing delays with account verification for customers in Indonesia. We are working with our service provider to rectify the issue.

We apologize for any inconvenience and will provide an update as soon as possible.
Posted Jul 28, 2022 - 07:13 UTC