Degraded performance
Incident Report for Luno
Resolved
Performance has been stable, thanks again for your patience.
Posted Jul 17, 2024 - 11:00 UTC
Monitoring
Between 20:24 and 20:36 UTC on 15 July 2024 we noticed slower than usual response times across all Luno services. Customers making us of the Exchange and API may noticed some issues during this time.

We're prioritising a fix to ensure we see better stability, sincerely sorry for any inconvenience caused.
Posted Jul 15, 2024 - 20:46 UTC