Delayed account verification in Indonesia

Incident Report for Luno

Resolved

This issue has been resolved. Thank you for your patience.
Posted Oct 14, 2025 - 06:45 UTC

Identified

We're currently experiencing a technical issue which is causing delays for new customer account verifications in Indonesia. We're actively working on resolving this. More updates to follow.
Posted Oct 13, 2025 - 16:43 UTC