Delayed withdrawals in South Africa

Incident Report for Luno

Resolved

Update:

We are no longer seeing any delays to withdrawals.

This service is working as intended.

We thank you for your patience and understanding
Posted Feb 26, 2026 - 13:14 UTC

Identified

Current Status: Customers initiating withdrawals will experience longer-than-usual processing times.

What you need to know:

We have identified an issue causing withdrawals to get stuck in processing for our South African customers.

We are working to resolve this as soon as possible. We appreciate your understanding in this matter.

Updates to follow.
Posted Feb 26, 2026 - 07:31 UTC