Trades and orders not showing on Android
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 09:50 UTC
Monitoring
The issue with trades and orders not showing has been resolved.

You will need to update the Luno app to the latest version from the play store in order to view trades and orders.

Thank you for your patience.
Posted Jun 11, 2021 - 13:43 UTC
Update
We are continuing to work on a fix for trades and orders not showing on Android devices.

We appreciate your patience.
Posted Jun 10, 2021 - 08:26 UTC
Identified
We have identified an issue with trades and orders on the Exchange on Android.

You may experience a blank screen when trying to view your trades or orders on the Exchange. Our team is aware and are working on a fix for this.

Trades and orders are still visible on web.
Posted Jun 09, 2021 - 06:47 UTC