All backlog transactions have been successfully processed, and there are no further delays with ETH sends.
We apologise for any inconvenience and appreciate your patience.
Posted Feb 18, 2025 - 00:11 UTC
Monitoring
A fix has been deployed and we are currently seeing no further issues with new ETH sends.
We are actively working through the backlog of pending withdrawals. Some customers may still experience delays, but we are monitoring the situation closely and continuing to address the backlog.
Posted Feb 17, 2025 - 23:45 UTC
Identified
We are currently investigating an issue which may be causing customers to experience delays when sending ETH.
We are working on this as a matter of priority and will provide updates as soon as they become available.