Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you

Here is the withdrawal processing schedule.
https://www.luno.com/help/en/articles/11000022934
Posted Aug 27, 2021 - 04:49 UTC
Monitoring
Kami mohon maaf jika terjadi delay pada penarikan instan (auto withdrawal) dana Anda, karena saat ini kami sedang melakukan maintenance pada sistem penarikan dana di Luno. Penarikan dana Anda akan tetap kami proses setiap dua jam pada hari kerja dengan jadwal sebagai berikut:

Senin - Khamis, 9:00 - 17:00 WIB
Jumat, 9:00 - 13:00 WIB

Kami sedang berupaya menyelesaikan proses maintenance ini secepat mungkin.

---

We apologise for the temporary delays with Indonesia withdrawals requested from 19th August onwards. In the meantime, we will process withdrawals every two hours within the following operating schedule:

Monday - Thursday, 9:00 - 17:00 WIB
Friday, 9:00 - 13:00 WIB

We are working on getting the system maintenance resolved soon and will let you know once we revert to our usual processing schedule.

Thank you.
Posted Aug 20, 2021 - 06:56 UTC
Identified
There may be temporary delays with Indonesia withdrawals requested on 19th August onwards. Withdrawals are currently process every two hours from Monday 9AM WIB to Friday 1PM WIB. We’re working to resolved this soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Aug 19, 2021 - 07:12 UTC