Fiat Pairs Temporarily Unavailable on Instant Buy & Sell

Incident Report for Luno

Resolved

The issue affecting fiat pairs on Instant Buy & Sell has now been resolved.

All fiat pairs are once again fully operational and available for trading. Crypto-to-crypto pairs remained unaffected throughout the incident.

We apologise for the inconvenience caused and thank you for your patience and understanding while our team worked to restore full service.
Posted May 27, 2026 - 23:37 UTC

Identified

We are currently experiencing an issue affecting fiat pairs on Instant Buy & Sell. As a result, fiat pairs are temporarily unavailable.

Crypto-to-crypto pairs remain fully operational and available for trading through Instant Buy & Sell.

Our team is actively working to resolve the issue as quickly as possible. We apologise for the inconvenience and appreciate your patience and understanding.
Posted May 27, 2026 - 20:37 UTC